Recent Changes - Search:

edit SideBar

GNU gettext


The GNU gettext package provides a set of tools and documentation for producing multi-lingual messages in programs. Tools include a set of conventions about how programs should be written to support message catalogs, a directory and file naming organization for the message catalogs, a runtime library which supports the retrieval of translated messages, and stand-alone programs for handling the translatable and the already translated strings. Gettext provides an easy to use library and tools for creating, using, and modifying natural language catalogs and is a powerful and simple method for internationalizing programs.

The library is available as 32-bit and 64-bit:

  • If you are compiling a 32-bit program, no special compiler options are needed.
  • If you are compiling a 64-bit program, you have to compile and link your application with "xlc -q64" or "gcc -maix64".


Current version: v0.17-1


Please note:

  • If you get the following error message
    Error: failed dependencies
    libxlsmp.a(smprt.o) is needed by gettext-0.17-1
then please install the RPM with the "--nodeps" switch!
  • If you get the following error message while trying to install gettext
    # rpm -U gettext-0.17-1.aix5.1.ppc.rpm
    error: failed dependencies:
    libglib-2.0.a( is needed by gettext-0.17-1
and as newer glib2 versions themselves have a dependency on gettext, you need to install it this way (the glib2 version might vary):
# rpm -U gettext-0.17-1.aix5.1.ppc.rpm --nodeps
# rpm -U glib2-2.20.5-1.aix5.1.ppc.rpm
Then it should work.
  • Starting with version 2.22.5-2 and 2.20.5-3 glib2 does not depend on gettext 0.17 anymore!



Source RPM:

Package dependencies:

All versions

Edit - History - Print - Recent Changes - Search
Page last modified on May 05, 2011, at 02:34 PM