Recent Changes - Search:

edit SideBar

Ganglia v3.7.2 binary RPMs with my POWER5/6/7/8 extensions

Starting with version 3.1.X Ganglia can be extended with DSOs (Dynamic Shared Objects). Here you find compiled versions of the Ganglia core system and my POWER5/6/7 extensions as DSOs.

Available for download

Please check the software prerequisites at the bottom of this page!


Ganglia core system


DSO for IBM POWER extensions (mod_ibmpower)


DSO for IBM rPerf and SPEC CPU2006 metrics (mod_ibmrperf)


AIX DSO for Active Memory Expansion (AME) (mod_ibmame)


DSO for Active Memory Sharing (AMS) (mod_ibmams)


AIX DSO for Fibre Channel devices (mod_ibmfc)


AIX DSO for Network devices (mod_ibmnet)


Linux DSO for Network devices (mod_netif)


AIX DSO for Disk devices (mod_aixdisk)


Software prerequisites

Starting with version 3.1.7 Ganglia needs at least the following additional packages:

  • apr
    • AIX
      • AIX packages can be found here
    • SLES 9
      • Use the libapr1 package provided by me
    • SLES 10 and higher
      • Use the libapr1 package that comes with SLES 10 (and higher)
    • openSUSE 10.0 and higher
      • Use the libapr1 package that comes with openSUSE
    • RHEL 4
      • Use the apr package provided by me
    • RHEL 5 and higher
      • Use the apr package that comes with RHEL
    • Fedora 4 and higher
      • Use the apr package that comes with Fedora
  • expat
    • AIX
      • AIX packages can be found here
    • SLES 9
      • Use the expat package that comes with SLES 9
    • SLES 10 and higher
      • Use the expat package that comes with SLES 10 (and higher)
    • openSUSE 10.0 and higher
      • Use the libexpat1 package that comes with openSUSE
    • RHEL 4 and higher
      • Use the expat package that comes with RHEL
    • Fedora 4 and higher
      • Use the expat package that comes with Fedora or compat-expat1 for newer Fedora versions
  • libConfuse
  • PCRE
    • AIX
      • AIX packages can be found here
    • SLES 9 and higher
      • Use the pcre package that comes with SLES
    • openSUSE 10.0 and higher
      • Use the pcre package that comes with openSUSE
    • RHEL 4 and higher
      • Use the pcre package that comes with RHEL
    • Fedora 4 and higher
      • Use the pcre package that comes with Fedora
  • Python (only required for the gmond python module)
    • AIX
      • AIX packages can be found here
    • SLES 9 and higher
      • Use the python package that comes with SLES
    • openSUSE 10.0 and higher
      • Use the python package that comes with openSUSE
    • RHEL 4 and higher
      • Use the python package that comes with RHEL
    • Fedora 4 and higher
      • Use the python package that comes with Fedora

Additional gmetad dependencies

  • RRDTool
    • AIX
      • AIX packages can be found here
    • SLES 9
      • Use the rrdool package provided by me
    • SLES 10 and higher
      • Use the rrdtool package that comes with SLES
    • openSUSE 10.0 and higher
      • Use the rrdtool package that comes with openSUSE
    • RHEL 4
    • RHEL 5
    • RHEL 6 and higher
      • Use the rrdtool package that comes with RHEL 6
    • Fedora 4 and higher
      • Use the rrdtool package that comes with Fedora

Source code and SPEC files

Edit - History - Print - Recent Changes - Search
Page last modified on October 20, 2016, at 10:56 PM